Appenate - Known issue with Google Sheets on Data Source connectors โ€“ Incident details

Known issue with Google Sheets on Data Source connectors

Resolved
Operational
Started over 3 years agoLasted about 2 hours

Affected

๐Ÿ‡ช๐Ÿ‡บ Europe Cloud

Operational from 11:43 PM to 1:30 AM

๐Ÿ‡ฆ๐Ÿ‡บ Australia Cloud

Operational from 11:43 PM to 1:30 AM

๐Ÿ‡บ๐Ÿ‡ธ USA Cloud

Operational from 11:43 PM to 1:30 AM

Updates
  • Resolved
    Resolved

    Issue has been verified as resolved.

  • Monitoring
    Monitoring

    We deployed the fix and are currently monitoring the result.

    We expect all affected Google Sheets Data Source connectors to automatically resume operation on their next scheduled run.

  • Identified
    Identified

    We have found a code fix for this issue, which is now in testing.

    Assuming testing is successful, we expect this fix to go live within the next hour.

  • Investigating
    Investigating

    Data Source Connectors to Google Sheets are currently failing across all nodes.

    We have found the root cause (an undocumented change by Google) and are working to update our code to match new Google requirements.

    A temporary workaround is to turn on "Link Sharing" (share to anyone with link) on your affected Sheets.