Scheduled Maintenance in Australia: February 25 , 00:00 – 00:30 AEDT
Scheduled for February 25, 2026 at 1:00 PM – February 24, 2026 at 1:43 PM
In progress
February 25, 2026 at 1:00 PMIn progress
February 25, 2026 at 1:00 PMWe will be performing scheduled maintenance.
Expected Downtime: Up to 30 minutes.
Service Impact: Logins and app syncing will be temporarily unavailable.
Offline Mode: The app will continue to function offline during this window; your data will sync once the maintenance is complete.
Completed
February 24, 2026 at 1:43 PMCompleted
February 24, 2026 at 1:43 PMMaintenance has completed successfully.